GibbsCAM Online
GibbsCAM Forums

Most Popular
Recently Added
Recently Updated

How do I reorient a solid body (v7.0 and older)?

Reorientation of a solid body using coordinate systems

This document is intended to provide a step-by-step procedure for reorienting an imported solid body. This example requires the use of coordinate systems which is only available if you have the Advanced Mill option. Most SolidSurfacer customers will have this option.

  1. Identify a planar (flat) surface on your imported body
  2. Depress the face selection button and select the planar face
  3. Open the CS list and create a new coordinate system
  4. Open the CS modification pallet (directly below the CS list button) and right-click on the Align Plane button and select Align Plane Through and Move. Be sure that your planar face is still selected for this step. If you have additional part bodies that need to be moved with your part be sure they are all selected for the next step.
  5. Select Modify-->Change CS (XYZ). This will associate the selected body with the new CS.
  6. Click on the XY preset on the CS modification pallet. This will modify the current CS to align with the XY plane. Your body may be upside down at this point. If it is select the Depth Axis button on the CS modification pallet.
  7. Select View-->Shrink Wrap.
  8. Change to CS#1
  9. Select the body and select Modify-->Change cs (XYZ)
  10. Highlight CS#2 in the CS list and click on the trashcan.
  11. Your part should now be oriented properly to the XY plane and should be fully contained within the stock definition.

    Next we will move the part origin to a desired point on the model.
  12. Turn on Edge Selection.
  13. Select an edge that would help identify the new origin. This could be a corner or a circle.
  14. Open the geometry pallet, select Geometry from Solids and select Geometry Extraction from the sub-menu.
  15. Specify a tolerance of .001" and click the Do It button. This should result in geometry being created from the edge selected. If you selected a circular shape it will be necessary to generate the center point of the circle at this point. This function can be found on the point pallet.
  16. Select Modify-->Move Part Origin.
  17. At this point it is important that the Origin dialog remain the active dialog. Be sure not to click any other feature or dialog after opening the Origin dialog.

  18. Hold down the ALT and SHIFT keys on your keyboard. The mouse pointer should turn into a square, Place the square over the point created in step #15 and click. This will load some values in the Origin Dialog. Hit Do It on the Origin dialog.

  19. You should now have your part in the correct orientation with the correct part origin

 


Properties ID: 000098   Views: 6159   Updated: 8 years ago
Filed under: